Convertir vídeos a MP4 (PSP/Movil) en Ubuntu 8.04

Recientemente me dejaron una psp y tenía la curiosidad de ver como se vería una serie/película en este medio, y la verdad es que quedé muy agradado, así que hoy os voy a contar la manera de convertir un video a MP4 desde nuestro Ubuntu, en mi caso 8.04.
El programa que vamos a usar es PSPVC (PSP Video Converter), una herramienta que nos proporciona un buen GUI para pasar nuestros vídeos al formato compatible con la PSP o muchos telefonos móviles.
Empecemos con la instalación:
1º Instalaremos las dependencias:

sudo apt-get install libfaac-dev libxvidcore4-dev libgtk2.0-dev nasm build-essential


2º Descargaremos el código fuente del programa: Aquí podeis encontrar la última versión

3º Una vez descargado, lo descomprimimos y lo instalamos con el siguiente comando:

sudo ./install.sh


Y listo, ya lo podeis encontrar en Aplicaciones -> Sonido y Vídeo -> PSPVC

9 comentarios:

eduardo vargas dijo...

Disculpa, pero soy novato con el Terminal. Ya he completado el paso 1 y 2 pero pero una vez tengo el paqute en el escritorio no sé como instalarlo, ¿Será que estoy escribiendo algo mal en el terminal?

PsYducKbug dijo...

Hola, no te preocupes que aquí estamos para ayudar. A ver primero tienes que descomprimir el archivo que te descargas de la página en el paso 2.
Lo puedes hacer desde el terminal con:

tar -xf pspvc-install-0.3.tar.gz
nos vamos a esa carpeta:
cd pspvc-install-0.3

y luego ya ejecutas el último paso:
sudo ./install.sh

Si tienes cualquier duda no dudes en preguntar

eduardo vargas dijo...

Muchas gracias por tu ayuda, ya lo pude instalar solo me faltaba localizar el archivo con cd pspvc-install-0.3.

sephole dijo...

Ayuda al instalar el convertidor, uso ubuntu 8.04, sigo los pasos bien pero cuando instalo el programana en la terminar mo pone mensajes de tipo:

./version.sh: 2: svnversion: not found
Platform: X86
System: LINUX
avis input: no
mp4 output: no
pthread: yes
gtk: no
debug: no
gprof: no
PIC: no
shared: no
visualize: no

You can run 'make' or 'make fprofiled' now.
gcc -O4 -ffast-math -Wall -I. -D__X264__ -DHAVE_MALLOC_H -DHAVE_MMXEXT -DHAVE_SSE2 -DARCH_X86 -DSYS_LINUX -DHAVE_PTHREAD -s -fomit-frame-pointer -c -o x264.o x264.c
x264.c:27:20: error: stdlib.h: No existe el fichero ó directorio
x264.c:32:20: error: signal.h: No existe el fichero ó directorio
x264.c:34:20: error: getopt.h: No existe el fichero ó directorio
En el fichero incluído de x264.c:45:
En el fichero incluído de common/common.h:105,
de x264.c:45:
./x264.h:32:4: aviso: #warning You must include stdint.h or inttypes.h before x264.h
In file included from common/common.h:105,
from x264.c:45:
./x264.h:185: error: expected specifier-qualifier-list before ‘uint8_t’
./x264.h:313: error: expected specifier-qualifier-list before ‘uint8_t’
In file included from common/common.h:106,
from x264.c:45:
common/bs.h:31: error: expected specifier-qualifier-list before ‘uint8_t’
common/bs.h: En la función ‘bs_init’:
common/bs.h:41: error: ‘bs_t’ no tiene un miembro llamado ‘p_start--

y un monton mas de errores.

PsYducKbug dijo...

Hola sephole, vamos a ver, prueba a instalar esto:

sudo apt-get install build-essential subversion

Salu2

sephole dijo...

Me muestra el error:

No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
build-essential: Depende: libc6-dev pero no va a instalarse o
libc-dev
Depende: g++ (>= 4:4.1.1) pero no va a instalarse
E: Paquetes rotos


Cuando intento con el primer paso de tu guia me da el mismo error pero me mensiona mas dependencias.

PsYducKbug dijo...

Prueba a hacer un:
sudo apt-get autoremove

y luego:
sudo apt-get clean

Para limpiar toda la morralla que tengas de paquetes rotos y cosas de esas. Luego intenta volver a instalar el:

sudo apt-get install build-essential

Y me cuentas si no va bien
Saludos

sephole dijo...

Igual, y me eh dado cuenta de que el ubunto tampoco se actualiza.

tengo menos de un mes que me cambie a Linux, recuerdo que cuando quería activar el universo y multiverso busque por internet y en una pagina me hicieron sobrescribí el archivo donde estaban las direcciones guardadas de donde ubunto se guía para descargar, lo hice y no hubo resultado luego active lo que quería por la forma gráfica pero deje el repositorio sobrescrito.

¿crees que tenga que ver con mi problema lo que te conté?

PsYducKbug dijo...

Hombre, si has tocado los repositorios puede que no estén muy allá, pero de todas formas haz lo que te dije.

Por otro lado haz en el terminal:

sudo gedit /etc/apt/source.list

y sustituye tu lista de repositorios por esto:

deb http://es.archive.ubuntu.com/ubuntu/ hardy-updates main restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ hardy-updates main restricted

deb http://es.archive.ubuntu.com/ubuntu/ hardy universe
deb-src http://es.archive.ubuntu.com/ubuntu/ hardy universe
deb http://es.archive.ubuntu.com/ubuntu/ hardy-updates universe
deb-src http://es.archive.ubuntu.com/ubuntu/ hardy-updates universe

deb http://es.archive.ubuntu.com/ubuntu/ hardy multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ hardy multiverse
deb http://es.archive.ubuntu.com/ubuntu/ hardy-updates multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ hardy-updates multiverse

deb http://security.ubuntu.com/ubuntu hardy-security main restricted
deb-src http://security.ubuntu.com/ubuntu hardy-security main restricted
deb http://security.ubuntu.com/ubuntu hardy-security universe
deb-src http://security.ubuntu.com/ubuntu hardy-security universe
deb http://security.ubuntu.com/ubuntu hardy-security multiverse
deb-src http://security.ubuntu.com/ubuntu hardy-security multiverse

Que es una lista de repositorios bastante limpia para UBUNTU 8.04