Problema Generating locales... actualización ubuntu 8.04

He visto al actualizar varias máquinas de Ubuntu 7.10 a 8.04 que cuando llega a la parte de "Generating locales..." se quedan congelado y no sigue con la instalación dejandote bloqueado cualquier programa de instalación de paquetes. Pues bien, os voy a contar como lo he solucionado:

Una vez se os queda bloqueado abrís un terminal y buscais el proceso que se encarga de generar las locales, con la siguiente orden:

ps aux | grep locale

os apareceran unos cuantos procesos y tendremos que ir matando procesos hasta dar con el que sea, con la orden:

sudo kill -9 Numero_de_proceso

El Numero_de_proceso viene identificado con la orden ps que os puse antes. Es el número de la segunda columna.

En mi caso fue este proceso:

root 20387 0.0 0.0 1772 316 pts/5 S+ 11:03 0:00 /bin/sh /usr/sbin/locale-gen

Tras hacer esto prosegirá con la instalación. Y al reiniciar estará todo instalado, aunque seguramente os dirá que hay un paquete roto que podries reparar y tener una instalación en perfectas condiciones ;)

2 comentarios:

jloe dijo...

A mí me ha pasado lo mismo. Sin embargo no hay forma de detener el proceso de generación de locales: ni desde consola con kill -9 pid, ni desde qps (gráfico), ni con control+c, sólo finalizando el proceso 'Padre' se puede detener.
No obstante no finaliza y sigue comiendo muchos recursos de memoria y de cpu, sólo acaba el proceso padre pero no el de generar locales. Cuantas veces vuelvo a lanzar el proceso se queda en el mismo punto, de tal forma que aparecen varios trabajos con el mismo proceso (localedef).
He conseguido pasar el proceso de la generación de locales arrancando desde un cd de recuperación (el de kubuntu 8.04 alternate, en modo rescate) y ejecutar en consola apt-get dist-upgrade para que continúe dónde se quedó.
Lo malo que no sé si el proceso completo de actualización de versión ha acabado bien o no, ya que tuve que actualizar el arranque del grub manualmente añadiendo la entrada con el kernel propio de la 8.04 (el 2.6.24-19-generic).
La versión de KDE sí que ha cambiado, ahora es la 3.5.9, pero no estoy seguro del resto.
Si alguien sabe algo más o la mejor manera de solucionarlo que, por favor, nos eche una mano. Muchas gracias.

Anónimo dijo...

Gracias, fue de gran ayuda. Estos fallos son imperdonables,